Список задач

Задача 20.2 пробного ГИА от 2016.03.10

Наверх

Условие

Напишите программу для решения следующей задачи. 
На  контрольной  работе  по  алгебре  ученикам 9 класса  было  предложено 
10 примеров.  Неудовлетворительная  оценка  выставляется,  если  правильно 
решено  менее  половины  примеров.  Сколько  неудовлетворительных  оценок 
было получено учениками? Если хотя бы один из учеников правильно решил 
все задачи, выведите YES, иначе – выведите NO. 
Программа получает на вход количество учеников в классе N (1 ≤ N ≤ 30), 
затем  для  каждого  ученика  вводится  количество  правильно  решённых 
примеров. 
Пример работы программы
Входные данные Выходные данные
4
3
9
2
8
2
no

Решение:

var
  n, i, a, k, f: integer;

begin
  readln(n);
  k := 0;
  f := 0;
  for i := 1 to n do
  begin
    readln(a);
    if a < 5 then k := k + 1;
    if a = 10 then f := 1;
  end;
  writeln(k);
  if f = 1 then writeln('yes') else writeln('no');
end.

Задача 20.2 демо ГИА 2016

Наверх

Условие

Напишите  программу,  которая  в  последовательности  натуральных  чисел 
определяет минимальное число, оканчивающееся на 4. Программа получает 
на  вход  количество  чисел  в  последовательности,  а  затем  сами  числа.  
В последовательности всегда имеется число, оканчивающееся на 4. 
Количество  чисел  не  превышает 1000. Введённые  числа  не  превышают  
30 000. 
Программа должна вывести одно число – минимальное число, оканчивающееся 
на 4.

Пример работы программы

Входные данные Выходные данные
3
24
14
34
14

Решение

var
  i, n, a, min: integer;

begin
  readln(n);
  min := 30000;
  for i := 1 to n do 
  begin
    readln(a);
    if (a mod 10 = 4) and (a < min) then
      min := a;
  end;
  writeln(min);
end. 

Задача 20.2 пробного ГИА от 2015.09.18

Наверх

Условие

Напишите программу, которая в последовательности натуральных чисел
находит среднее арифметическое трёхзначных чисел или сообщает, что таких
чисел нет (выводит NO). Программа получает на вход натуральные числа,
количество введённых чисел неизвестно, последовательность чисел
заканчивается числом 0 (0 – признак окончания ввода, не входит
в последовательность).
Количество чисел не превышает 100. Введённые числа не превышают 300.
Программа должна вывести среднее арифметическое трёхзначных чисел или
вывести «NO», если таких чисел нет. 
Пример работы программы:
Входные данные Выходные данные
10
120
125
0
122.5
11
1
0
NO

Решение:

var
  a, k, s: integer;

begin
  s := 0;
  k := 0;
  readln(a);
  while a <> 0 do 
  begin
    if (a > 99) and (a < 301) then begin
      k := k + 1;
      s := s + a;
    end;
    readln(a);
  end;
  if k = 0 then writeln('no') else writeln(s / k);
end.

Задача 20.2 вариант 1 из задачника ГИА 2014

Наверх

Условие

Напишите программу, которая в последовательности натуральных чисел
определяет количество четных отрицательных чисел. Программа получает на вход натуральные числа,
количество введённых чисел неизвестно, последовательность чисел
заканчивается числом 0 (0 – признак окончания ввода, не входит
в последовательность).
Количество введеных чисел не превышает 1000. Введённые числа не превышают 30 000.
Программа должна вывести одно числоЖ количество четных отрицательных чисел.
Пример работы программы:
Входные данные Выходные данные
-17
2
-6
0
1

Решение:

var
  k, n: integer;

begin
  k := 0;
  readln(n);
  while n <> 0 do 
  begin
    if (n mod 2 = 0) and (n < 0) then k := k + 1;
    readln(n);
  end;
  writeln(k);
end.